GNU:s bildmanipuleringsprogram

Användarhandbok

Juridisk information

Tillåtelse ges för att kopiera, distribuera och/eller ändra detta dokument under villkoren för GNU Free Documentation License, version 1.2 eller någon senare version publicerad av Free Software Foundation; utan oföränderliga avsnitt, inga framsidestexter och inga baksidestexter. En kopia av licensen har inkluderats i avsnittet GNU Free Documentation License.


Innehållsförteckning

Förord
1. Författare och bidragsgivare till GIMPs användarhandbok
I. Komma igång
1. Introduktion
1. Välkommen till GIMP
1.1. Upphovsmän
1.2. GIMPs hjälpsystem
1.3. Funktioner och förmågor
2. Vad är nytt i GIMP 2.10.18?
2. Starta upp GIMP
1. Köra GIMP
1.1. Kända plattformar
1.2. Språk
1.3. Kommandoradsargument
2. Starta GIMP för första gången
2.1. Slutligen…
3. Första stegen med Wilber
1. Grundläggande begrepp
2. Huvudfönster
2.1. Verktygslådan
2.2. Bildfönster
2.3. Dialoger och dockning
3. Ångra
3.1. Saker som inte kan ångras
4. Vanliga uppgifter
4.1. Syfte
4.2. Ändra storleken på en bild för skärmen
4.3. Ändra storleken på en bild för utskrift
4.4. Komprimera bilder
4.5. Beskär en bild
4.6. Hitta information om din bild
4.7. Ändra läget
4.8. Vänd en bild
4.9. Rotera en bild
4.10. Separera ett objekt från sin bakgrund
5. Hur du ritar raka linjer
5.1. Syfte
5.2. Exempel
4. Vad du kan göra när du kört fast
1. Introduktion
2. Vanliga orsaker till att GIMP inte svarar
2.1. Det finns en flytande markering
2.2. Markeringen är dold
2.3. Du arbetar utanför markeringen
2.4. Den aktiva ritytan är inte synlig
2.5. Den aktiva ritytan är transparent
2.6. Du försöka arbeta utanför lagret
2.7. Du försöker arbeta på en lagergrupp
2.8. Bilden är i indexerat färgläge.
2.9. Ingen synlig effekt vid försök att använda en pensel, suddgummit eller andra verktyg
2.10. Suddgummit och penslar fungerar inte längre
2.11. Suddgummit gör inte området transparent
2.12. Oväntade färger vid försök att använda en pensel eller suddgummit
3. Hur du fixar saknade fönster och dialogrutor
3.1. Alla verktygsfönster saknas
3.2. Dialogrutan för verktygsalternativ saknas
3.3. Några av verktygsikonerna saknas
II. Hur blir jag en GIMP-gud?
5. Få in bilder i GIMP
1. Bildtyper
2. Skapa nya filer
3. Öppna filer
3.1. Öppna fil
3.2. Öppna plats
3.3. Öppna tidigare
3.4. Använda externa program
3.5. Filhanterare
3.6. Dra och släpp
3.7. Kopiera och klistra in
3.8. Bildbläddrare
6. Få ut bilder från GIMP
1. Filer
1.1. Save / Export Images
1.2. Filformat
2. Förbered dina bilder för webben
2.1. Images with an Optimal Size/Quality Ratio
2.2. Reducing the File Size Even More
2.3. Spara bilder med transparens
7. Rita med GIMP
1. Markeringen
1.1. Fjädring
1.2. Göra en markering delvis transparent
2. Skapa och använda markeringar
2.1. Flytta en markering
2.2. Lägg till eller ta bort markeringar
3. Snabbmasken
3.1. Översikt
3.2. Egenskaper
4. Använda snabbmaskläge
5. Banor
5.1. Path Creation
5.2. Path Properties
5.3. Banor och markeringar
5.4. Transformera banor
5.5. Stroking a Path
5.6. Banor och text
5.7. Banor och SVG-filer
6. Penslar
7. Lägg till nya penslar
8. The GIH Dialog Box
9. Changing brush size
9.1. How to change the size of a brush
9.2. Creating a brush quickly
10. Gradienter
11. Mönster
12. Paletter
12.1. Färgkarta
13. Förinställningar
14. Rita enkla objekt
14.1. Rita en rak linje
14.2. Creating a Basic Shape
8. Kombinera bilder
1. Introduktion till lager
1.1. Lageregenskaper
2. Lagerlägen
3. Skapa nya lager
4. Lagergrupper
9. Texthantering
1. Texthantering
1.1. Textområde
1.2. Hantera textlager
1.3. Textverktygslåda
1.4. Snabbvalsmeny för text
2. Text
2.1. Embellishing Text
2.2. Lägg till typsnitt
2.3. Typsnittsproblem
10. Förbättra fotografier
1. Arbeta med digitalkamerabilder
1.1. Introduktion
1.2. Improving Composition
1.3. Förbättra färger
1.4. Adjusting Sharpness
1.5. Removing Unwanted Objects from an Image
1.6. Spara ditt resultat
11. Färghantering med GIMP
1. Färghantering i GIMP
1.1. Problem med arbetsflöden utan färghantering
1.2. Introduktion till färghanterat arbetsflöde
12. Berika mitt GIMP
1. Preferences Dialog
1.1. Introduktion
1.2. System Resources
1.3. Färghantering
1.4. Image Import and Export
1.5. Tool Options
1.6. Default Image Preferences
1.7. Default Image Grid
1.8. Gränssnitt
1.9. Tema
1.10. Icon Theme
1.11. Verktygslåda
1.12. Dialog Defaults
1.13. Help System
1.14. Skärm
1.15. Fönsterhantering
1.16. Bildfönster
1.17. Image Window Appearance
1.18. Image Window Title and Statusbar
1.19. Image Window Snapping Behavior
1.20. Inmatningsenheter
1.21. Input Controllers
1.22. Mappar
1.23. Data Folders
2. Rutnät och hjälplinjer
2.1. Bildrutnätet
2.2. Hjälplinjer
3. Rendering a Grid
4. How to Set Your Tile Cache
5. Creating Shortcuts to Menu Functions
6. Anpassa startbilden
13. Skriptning
1. Insticksmoduler
1.1. Introduktion
1.2. Använda insticksmoduler
1.3. Installera nya insticksmoduler
1.4. Skriva insticksmoduler
2. Använda Script-Fu-skript
2.1. Script-Fu?
2.2. Installing Script-Fu scripts
2.3. Så gör man och så gör man inte
2.4. Olika sorters Script-Fu
2.5. Bildberoende skript
3. A Script-Fu Tutorial
3.1. Getting Acquainted With Scheme
3.2. Variables And Functions
3.3. Lists, Lists And More Lists
3.4. Ditt första Script-Fu-skript
3.5. Giving Our Script Some Guts
3.6. Extending The Text Box Script
3.7. Ditt skript och hur det fungerar
III. Funktionsreferens
14. Verktyg
1. Verktygslådan
1.1. Introduction
1.2. Tool Icons
1.3. Color and Indicator Area
1.4. Tool Options
2. Markeringsverktyg
2.1. Common Features
2.2. Rectangle Selection
2.3. Ellipse Selection
2.4. Free Selection (Lasso)
2.5. Fuzzy selection (Magic wand)
2.6. Markera efter färg
2.7. Intelligent Scissors
2.8. Förgrundsmarkering
3. Paint Tools
3.1. Common Features
3.2. Dynamics
3.3. Brush Tools (Pencil, Paintbrush, Airbrush)
3.4. Fyll
3.5. Gradient
3.6. Penna
3.7. Pensel
3.8. MyPaint Brush
3.9. Suddare
3.10. Färgspruta
3.11. Bläck
3.12. Klona
3.13. Läk
3.14. Perspektivkloning
3.15. Blur/Sharpen
3.16. Smeta
3.17. Blek/Bränn
4. Transformeringsverktyg
4.1. Common Features
4.2. Arrangera
4.3. Flytta
4.4. Beskär
4.5. Rotera
4.6. Skala
4.7. Luta
4.8. Perspektiv
4.9. 3D Transform
4.10. Unified Transform
4.11. Handle Transform
4.12. Vänd
4.13. The Cage Tool
4.14. Warp Transform
5. Other
5.1. Översikt
5.2. Hjälplinjer
5.3. Färgväljare
5.4. Zooma
5.5. Measure
5.6. Text
5.7. GEGL Operation
15. Dialogrutor
1. Introduktion till dialogrutor
2. Dialogrutor relaterade till bildstruktur
2.1. Dialogrutan Lager
2.2. Dialogrutan Kanaler
2.3. Dialogrutan Slingor
2.4. Dialogrutan Färgkarta
2.5. Dialogrutan Histogram
2.6. Dialogrutan Navigering
2.7. Dialogrutan Ångringshistorik
3. Dialogrutor relaterade till bildinnehåll
3.1. FG/BG Color Dialog
3.2. Dialogrutan Penslar
3.3. Dialogrutan Mönster
3.4. Dialogrutan Gradienter
3.5. Dialogrutan Paletter
3.6. Tagging
3.7. Dialogrutan Typsnitt
4. Dialogrutor relaterade till bildhantering
4.1. Dialogrutan Buffertar
4.2. Dialogrutan Bilder
4.3. Dialogrutan Dokumenthistorik
4.4. Dialogrutan Mallar
5. Miscellaneous Dialogs
5.1. Tool Presets Dialog
5.2. Tool Preset Editor
5.3. Dialogrutan Enhetsstatus
5.4. Felkonsoll
5.5. Dashboard
5.6. Save File
5.7. Exportera fil
5.8. Dialogrutan Samplingspunkter
5.9. Dialogrutan Pekare
5.10. Symmetry Painting dialog
16. Menyer
1. Introduktion till menyer
1.1. Bildmenyraden
1.2. Snabbvalsmenyer
1.3. Löstagbara menyer
1.4. Flikmenyer
2. Arkiv-menyn
2.1. Översikt
2.2. New…
2.3. Skapa
2.4. File Open…
2.5. Open as Layers…
2.6. Open Location…
2.7. Open Recent
2.8. Spara
2.9. Save as…
2.10. Save a Copy…
2.11. Revert
2.12. Export…
2.13. Export As…
2.14. Create Template…
2.15. Skriv ut
2.16. Send by Email
2.17. Copy Image Location
2.18. Show in File Manager
2.19. Stäng
2.20. Stäng alla
2.21. Avsluta
3. Redigera-menyn
3.1. Edit Menu Entries
3.2. Ångra
3.3. Gör om
3.4. Ångringshistorik
3.5. Klipp ut
3.6. Kopiera
3.7. Kopiera synlig
3.8. Klistra in
3.9. Paste Into Selection
3.10. Paste In Place
3.11. Paste Into Selection In Place
3.12. Paste as
3.13. Buffert
3.14. Töm
3.15. Fyll med förgrundsfärg
3.16. Fyll med bakgrundsfärg
3.17. Fyll med mönster
3.18. Fill Selection Outline
3.19. Fill Path
3.20. Stroke Selection
3.21. Stroke Path
3.22. The Preferences Command
3.23. Tangentbordsgenvägar
3.24. Modules
3.25. Enheter
4. Markera-menyn
4.1. Introduktion till Markera-menyn
4.2. Markera allt
4.3. None
4.4. Invertera
4.5. Float
4.6. By Color
4.7. From Path
4.8. Selection Editor
4.9. Feather
4.10. Sharpen
4.11. Shrink
4.12. Grow
4.13. Border
4.14. Remove Holes
4.15. Distort
4.16. Rounded Rectangle
4.17. Toggle QuickMask
4.18. Spara till kanal
4.19. To Path
5. Visa-menyn
5.1. Introduction to the View Menu
5.2. Ny vy
5.3. Show All
5.4. Punkt för punkt
5.5. Zooma
5.6. Flip & Rotate (0°)
5.7. Center Image in Window
5.8. Shrink Wrap
5.9. Helskärm
5.10. Navigeringsfönster
5.11. Visningsfilter
5.12. Färghantering
5.13. Visa markering
5.14. Show Layer Boundary
5.15. Visa hjälplinjer
5.16. Visa rutnät
5.17. Visa samplingspunkter
5.18. Fäst mot hjälplinjer
5.19. Fäst mot rutnät
5.20. Snap to Canvas
5.21. Snap to Active Path
5.22. Padding Color
5.23. Visa menyrad
5.24. Visa linjaler
5.25. Visa rullningslister
5.26. Visa statusrad
6. Bild-menyn
6.1. Overview
6.2. Duplicate
6.3. Läge
6.4. RGB-läge
6.5. Grayscale mode
6.6. Indexed mode
6.7. Precision
6.8. Color Management
6.9. Enable Color Management
6.10. Assign Color Profile
6.11. Convert to Color Profile
6.12. Discard Color Profile
6.13. Save Color Profile to File
6.14. Transformera
6.15. Flip Horizontally; Flip Vertically
6.16. Rotation
6.17. Canvas Size
6.18. Fit Canvas to Layers
6.19. Fit Canvas to Selection
6.20. Print Size
6.21. Skala bild
6.22. Crop Image
6.23. Slice Using Guides
6.24. Zealous Crop
6.25. Sammanfoga synliga lager
6.26. Flatten Image
6.27. Align Visible Layers…
6.28. Hjälplinjer
6.29. Ny hjälplinje
6.30. New Guide (by Percent)
6.31. New Guides from Selection
6.32. Ta bort alla hjälplinjer
6.33. Configure Grid…
6.34. Bildegenskaper
6.35. Metadata
6.36. Metadata Viewer
6.37. Metadata Editor
7. Lager-menyn
7.1. Introduction to the Layer Menu
7.2. Nytt lager
7.3. New Layer Group
7.4. New From Visible
7.5. Duplicate layer
7.6. Förankra lager
7.7. Merge Down
7.8. Delete Layer
7.9. The Text Commands of the Layer Menu
7.10. Förkasta textinformation
7.11. Stack Submenu
7.12. Select Previous Layer
7.13. Välj nästa lager
7.14. Select Top Layer
7.15. Select Bottom Layer
7.16. Höj lager
7.17. Lower Layer
7.18. Layer to Top
7.19. Layer to Bottom
7.20. The Reverse Layer Order command
7.21. The Mask Submenu
7.22. Lägg till lagermask
7.23. Tillämpa lagermask
7.24. Ta bort lagermask
7.25. Visa lagermask
7.26. Redigera lagermask
7.27. Inaktivera lagermask
7.28. Mask till markering
7.29. Add Layer Mask to Selection
7.30. Subtract Layer Mask from Selection
7.31. Intersect Layer Mask with Selection
7.32. The Transparency Submenu of the Layer menu
7.33. Lägg till alfakanal
7.34. Ta bort alfakanal
7.35. Färg till alfa
7.36. Semi-flatten
7.37. Threshold Alpha
7.38. Alpha to Selection
7.39. Add Alpha channel to Selection
7.40. Subtract from Selection
7.41. Intersect Alpha channel with Selection
7.42. The Transform Submenu
7.43. Flip Horizontally
7.44. Flip Vertically
7.45. Rotate 90° clockwise
7.46. Rotate 90° counter-clockwise
7.47. Rotate 180°
7.48. Arbitrary Rotation
7.49. Offset
7.50. Layer Boundary Size
7.51. Layer to Image Size
7.52. Scale Layer
7.53. Beskär lager
8. Färg-menyn
8.1. Introduction to the Colors Menu
8.2. Color Balance
8.3. Color Temperature
8.4. Hue Chroma
8.5. Hue-Saturation
8.6. Mättnad
8.7. Exposure
8.8. Shadows-Highlights
8.9. Brightness-Contrast
8.10. Levels
8.11. Curves
8.12. Invertera
8.13. Linear Invert
8.14. Value Invert
8.15. The Auto Submenu
8.16. Jämna ut
8.17. Vitbalans
8.18. Sträck ut kontrast
8.19. Sträck ut NMI
8.20. Förbättra färger
8.21. Förbättra färger (föråldrad)
8.22. The Components Submenu
8.23. Channel Mixer
8.24. Extract Component
8.25. Mono Mixer
8.26. Compose
8.27. Decompose
8.28. Recompose
8.29. Färg till grå
8.30. Avmätta
8.31. Sepia
8.32. The Map Submenu
8.33. Rearrange Colormap
8.34. Set Colormap
8.35. Alien Map
8.36. Color Exchange
8.37. Rotate Colors
8.38. Gradient Map
8.39. Palette Map
8.40. Sample Colorize
8.41. Fattal et al. 2002
8.42. Mantiuk 2006
8.43. Reinhard 2005
8.44. Belasta
8.45. Retinex
8.46. The Info Submenu
8.47. Histogram
8.48. Kantmedelvärde
8.49. Färgkubsanalys
8.50. Exportera histogram
8.51. Utjämnad palett
8.52. Threshold
8.53. Colorize
8.54. Posterize
8.55. Color to Alpha…
8.56. Dither
8.57. RGB Clip
8.58. Hot…
9. Verktyg-menyn
9.1. Introduktion till Verktyg-menyn
10. Filter-menyn
10.1. Introduction to the Filters Menu
10.2. Upprepa senaste
10.3. Re-show Last
10.4. Reset All Filters
10.5. The Python-Fu Submenu
10.6. Undermenyn Script-Fu
11. Fönster-menyn
12. Hjälp-menyn
12.1. Introduktion till Hjälp-menyn
12.2. Hjälp
12.3. Sammanhangshjälp
12.4. Dagens tips
12.5. Om
12.6. Insticksbläddrare
12.7. Procedurbläddrare
12.8. GIMP på nätet
17. Filter
1. Introduktion
2. Gemensamma funktioner
3. Oskärpefilter
3.1. Introduktion
3.2. Gaussian Blur
3.3. Mean Curvature Blur
3.4. Median Blur
3.5. Pixelize
3.6. Selective Gaussian Blur
3.7. Circular Motion Blur
3.8. Linear Motion Blur
3.9. Zoom Motion Blur
3.10. Tileable Blur
4. Förbättringsfilter
4.1. Introduktion
4.2. Antialias
4.3. Deinterlace
4.4. High Pass
4.5. Noise Reduction
4.6. Ta bort röda ögon
4.7. Symmetric Nearest Neighbor
4.8. Sharpen (Unsharp Mask)
4.9. Despeckle
4.10. Destripe
4.11. NL Filter
4.12. Wavelet Decompose
5. Förvrängningsfilter
5.1. Introduktion
5.2. Apply Lens
5.3. Emboss
5.4. Engrave
5.5. Linsdistortion
5.6. Mosaic
5.7. Newsprint
5.8. Polar Coordinates
5.9. Ripple
5.10. Skift
5.11. Spherize
5.12. Value Propagate
5.13. Video
5.14. Waves
5.15. Whirl and Pinch
5.16. Wind
5.17. Curve Bend
5.18. Emboss (legacy)
5.19. Page Curl
6. Ljus och skugg-filter
6.1. Introduktion
6.2. Supernova
6.3. Lens Flare
6.4. Gradient Flare
6.5. Lighting Effects
6.6. Sparkle
6.7. Drop Shadow
6.8. Long Shadow
6.9. Vignette
6.10. Drop Shadow (legacy)
6.11. Perspektiv
6.12. Xach-Effect
7. Brusfilter
7.1. Introduktion
7.2. CIE lch Noise
7.3. HSV Noise
7.4. Hurl
7.5. Pick
7.6. RGB Noise
7.7. Slur
7.8. Spread
8. Leta kanter-filter
8.1. Introduktion
8.2. Difference of Gaussians
8.3. Kant
8.4. Laplace
8.5. Neon
8.6. Sobel
8.7. Image Gradient
9. Generiska filter
9.1. Introduktion
9.2. Faltningsmatris
9.3. Avståndskarta
9.4. GEGL-graf
9.5. Normalmappning
9.6. Utvidga
9.7. Erodera
10. Kombineringsfilter
10.1. Introduktion
10.2. Depth Merge
10.3. Filmstrip
11. Artistiska filter
11.1. Introduktion
11.2. Apply Canvas
11.3. Cartoon
11.4. Cubism
11.5. Glass Tile
11.6. Oilify
11.7. Photocopy
11.8. Simple Linear Iterative Clustering (SLIC)
11.9. Softglow
11.10. Waterpixels
11.11. Cartoon (legacy)
11.12. Clothify
11.13. GIMPressionist
11.14. Oilify (legacy)
11.15. Predator
11.16. Softglow (legacy)
11.17. Van Gogh (LIC)
11.18. Weave
12. Dekoreringsfilter
12.1. Introduktion
12.2. Add Bevel
12.3. Add Border
12.4. Coffee Stain
12.5. Fog
12.6. Fuzzy Border
12.7. Old Photo
12.8. Round Corners
12.9. Slide
12.10. Stencil Carve
12.11. Stencil Chrome
13. Mappningsfilter
13.1. Introduktion
13.2. Bump Map
13.3. Displace
13.4. Fractal Trace
13.5. Illusion
13.6. Little Planet
13.7. Panorama Projection
13.8. Recursive Transform
13.9. Paper Tile
13.10. Tile Seamless
13.11. Fractal Trace (legacy)
13.12. Map Object
13.13. Bricka
14. Renderingsfilter
14.1. Introduktion
14.2. Flame
14.3. Fractal Explorer
14.4. IFS Fractal
14.5. Cell Noise
14.6. Perlin Noise
14.7. Plasma
14.8. Simplex Noise
14.9. Solid Noise
14.10. Difference Clouds
14.11. Bayer Matrix
14.12. Checkerboard
14.13. Diffraction Patterns
14.14. Rutnät
14.15. Maze
14.16. Sinus
14.17. Checkerboard (legacy)
14.18. CML Explorer
14.19. Grid (legacy)
14.20. Jigsaw
14.21. Qbist
14.22. Circuit
14.23. Gfig
14.24. Lava
14.25. Line Nova
14.26. Sphere Designer
14.27. Spyrogimp
15. Webbfilter
15.1. Introduktion
15.2. ImageMap
15.3. Semi-Flatten
15.4. Slice
16. Animationsfilter
16.1. Introduktion
16.2. Intoning
16.3. Inbränning
16.4. Krusning
16.5. Roterande glob
16.6. Vågor
16.7. Optimera
16.8. Uppspelning
I. Referens för tangenter och mus
Arkiv — Tangentreferens för menyn Arkiv
Redigera — Tangentreferens för menyn Redigera
Markera — Tangentreferens för menyn Markera
Visa — Tangentreferens för menyn Visa
Bild — Tangentreferens för menyn Bild
Lager — Tangentreferens för menyn Lager
Verktyg — Tangentreferens för menyn Verktyg
Filter — Tangentreferens för menyn Filter
Fönster — Tangentreferens för menyn Fönster
Hjälp — Tangentreferens för menyn Hjälp
Zoomverktyg — Tangentreferens för Zoomverktyget
Ordlista
Källförteckning
A. Historien om GIMP
1. Från första början
2. De tidiga dagarna för GIMP
3. The One to Change the World
4. Version 2.0
5. Vad är nytt i GIMP 2.2?
6. Vad är nytt i GIMP 2.4?
7. Vad är nytt i GIMP 2.6?
8. What's New in GIMP 2.8?
9. What's new in GIMP 2.10?
B. Rapportera fel och begära förbättringar
1. Försäkra dig om att det är ett fel
2. Rapportera felet
C. How to Contribute
1. Prerequisites
1.1. Join our mailing list
1.2. Create a Local Working Copy of Code
1.3. Installing your sandbox
1.4. The gimp-help folder
2. Workflow
2.1. Writing
2.2. Validating
2.3. Images
2.4. Create HTML Files
2.5. Sending your files
3. Annexes
4. Working under Windows
4.1. Adapting Cygwin to use with GIMP documentation tools
D. Tone Mapping and Shadow Recovery Using GIMP’s ‘Colors/Exposure’
1. High bit depth GIMP’s floating point “Colors/Exposure”: much better than Curves for lightening the shadows and midtones of an image without blowing the highlights
2. A step-by-step example showing how to recover shadow information using high bit depth GIMP’s floating point “Colors/Exposure”
3. Use Notes
4. Conclusion
E. GNU Free Documentation License
1. BAKGRUND
2. TILLÄMPNINGSOMRÅDE OCH DEFINITIONER
3. ORDAGRANN KOPIERING
4. OMFATTANDE KOPIERING
5. FÖRÄNDRINGAR
6. KOMBINERA DOKUMENT
7. SAMLINGAR AV DOKUMENT
8. SAMMANSLAGNING MED OBEROENDE VERK
9. ÖVERSÄTTNING
10. UPPHÖRANDE
11. FRAMTIDA VERSIONER AV DENNA LICENS
12. TILLÄGG: Hur du använder denna licens för dina dokument
F. Ooops! Hjälp saknas
Index